Some meeting rooms not accessible

Major incident Videoconferencing
6 minutes, 21 seconds

Updates

Resolved

Issue has been resolved

March 17, 2020 · 18:35 CET
Investigating

Some meeting rooms are inaccessible.

March 17, 2020 · 18:29 CET

← Back