Unforseen downtime

Major incident Website - landing pages Videoconferencing Meeting scheduling API
2020-04-20 17:14 CEST · 7 minutes, 30 seconds

Updates

Resolved

Issue resolved - peak use in queries - looking to limit use and prevent future downtime.

April 20, 2020 · 17:21 CEST
Issue

Unexpected downtime - working to fix this issue

April 20, 2020 · 17:15 CEST

← Back