Google Calendar is down
      
Major incident
      
        Meeting scheduling
    
    
      
2023-09-21 16:33 CEST
      
      · 2 hours, 24 minutes
    
  Updates
          Resolved
        
        
September 21, 2023 · 18:56 CEST
        
      
      Google calendar issue is fixed. The scheduling features that use Google Calendar in Vectera work again.
          Monitoring
        
        
September 21, 2023 · 16:33 CEST
        
      
  Due to an incident in Google Calendar the scheduling features in Vectera might have issues.
← Back
 Current availability and history of incidents
            
Current availability and history of incidents