Booking pages partially don't work due to general Outlook/exchange issue

Minor incident Meeting scheduling
2024-11-25 10:01 CET · 1 day, 23 hours, 20 minutes

Updates

Resolved

Microsoft has updated the status to ‘Everything is up and running’.
https://portal.office.com/servicestatus

November 27, 2024 · 00:00 CET
Monitoring

Microsoft has reverted the latest deploy which seems to fix the issue for most cases.

November 25, 2024 · 19:00 CET
Issue

Booking pages of users that have connected to Outlook/Exchange calendar don’t work because of general Microsoft outage.

November 25, 2024 · 10:30 CET

← Back