Vectera is down

Major incident Website - landing pages Videoconferencing Meeting scheduling Emails Chrome extension API Subscription management
2025-04-21 08:00 CEST · 4 hours, 2 minutes

Updates

Resolved

The problem seems to be resolved. The dashboard, meeting room and booking pages work again.

Note:

  • Cancelling an appointment might not update in Microsoft calendar (outlook/O365)
April 21, 2025 · 11:58 CEST
Issue

There is a general outage of the platform. Our devs are investigating the issue.

April 21, 2025 · 10:48 CEST

← Back