Vectera Meeting Rooms are slow or unavailable

Major incident Videoconferencing
2020-11-05 10:44 CEST · 1 minute, 51 seconds

Updates

Resolved

The issue has been resolved. Vectera is available again.

November 5, 2020 · 10:46 CEST
Investigating

Our engineering team is actively investigating this incident and working to bring Vectera back up as quickly as possible.

November 5, 2020 · 10:45 CEST

← Back