There are multiple issues in the latest version of Safari

Minor incident Videoconferencing
2020-11-19 12:23 CEST · 2 months, 2 weeks, 4 days, 1 hour, 27 minutes, 9 seconds

Updates

Resolved

MacOS update to 11.2 and iOS update to 14.3 have resolved the issues.

February 5, 2021 · 13:50 CEST
Monitoring

There are multiple issues in the latest version of Safari that impact all video meeting software. We’re sorry for the inconvenience.

As a short term solution, we advise to join meeting rooms using another browser (eg. Google Chrome or Mozilla FireFox).

November 19, 2020 · 12:26 CEST

← Back