Landing pages are unaccessible

Major incident Website - landing pages
2021-06-08 12:32 CEST · 41 minutes, 9 seconds

Updates

Resolved

Issues have been resolved and landing pages are accessible again.

June 8, 2021 · 13:13 CEST
Investigating

Landing pages are down due to issues with a service provider.

June 8, 2021 · 12:33 CEST

← Back