Google Calendar is down

Major incident Meeting scheduling
2021-12-08 10:31 CEST · 1 hour, 25 minutes

Updates

Resolved

Google Calendar is back online.

December 8, 2021 · 11:56 CEST
Issue

Google Calendar is globally down and affects scheduling for all accounts connected to Google Calendar. Scheduling pages sometimes load, sometimes they don’t (and we want them to always load of course).

We’re keeping track of any updates on Googles part and will update this page accordingly.

December 8, 2021 · 10:33 CEST

← Back