Issue with managing subscriptions

Minor incident Subscription management
2021-12-22 14:33 CEST · 3 hours, 22 minutes

Updates

Resolved

Services are stable again. If any issues remain unsolved, please contact us at [email protected]

December 22, 2021 · 17:56 CEST
Issue

Managing your subscription is currently not possible due to an outage with our provider. Updates will follow when available.

December 22, 2021 · 14:35 CEST

← Back