Decreased stability - heavy load

Major incident Videoconferencing
2020-03-16 15:07 CEST · 23 minutes, 30 seconds

Updates

Resolved

Services all stable again

March 16, 2020 · 15:31 CEST
Issue

Occasional drops can occur in meetings due to extreme traffic. We’re working hard to scale up the services.

March 16, 2020 · 15:09 CEST

← Back